LodgeWorks IT - Core Services - Office 365 Email isn't accessible at the moment – Incident details

Experiencing partial outage

Core Services - Office 365 Email isn't accessible at the moment

Resolved
Major outage
Started 2 months agoLasted about 1 hour

Affected

Core Services

Operational from 1:10 PM to 1:10 PM, Major outage from 1:10 PM to 2:28 PM, Operational from 2:28 PM to 2:28 PM

Office 365 Email

Operational from 1:10 PM to 1:10 PM, Major outage from 1:10 PM to 2:28 PM, Operational from 2:28 PM to 2:28 PM

Updates
  • Resolved
    Resolved

    Core Services - Office 365 Email All services are now operational

  • Investigating
    Investigating

    Core Services - Office 365 Email We've been made aware of a possible service disruption. We will update you when we know more.