Show current status

[Resolved] Users experiencing Outlook connection issues and crashes

Started on July 15, 2020 at 7:10 PM. Resolved after less than a minute

Affected

Office 365 Email
  • Resolved
    July 15, 2020 at 7:10 PM  –  

    Users may experience crashes or may be unable to access Microsoft Exchange Online via Outlook