Show current status

[Resolved] Yonkers Internet down

Started on September 17, 2020 at 6:03 PM. Resolved after about 20 hours

Affected

Property Internet
  • Investigating
    September 17, 2020 at 6:03 PM  –  

    We are currently investigating this incident. Yonkers internet down at 12:55pm.

  • Resolved
    September 18, 2020 at 2:18 PM  –  

    We just resolved the issue. Came back up around 4:50pm.