Show current status

[Resolved] Burlington Internet Down

Started on January 25, 2021 at 2:18 PM. Resolved after 31 minutes

Affected

Property Internet
  • Investigating
    January 25, 2021 at 2:18 PM  –  

    We are currently investigating the cause of the incident. It appears the outage is at the provider (Comcast) level.

  • Resolved
    January 25, 2021 at 2:49 PM  –  

    We just resolved the issue!